Raw water wash down - SaltwaterCentral.Com

Post new topic   Reply to topic
 

rxheels
Posts: 36
Reply with quote
Mon May 27, 2019 12:04 pm
My raw water wash down will not pump water. When I switch it on I can hear the pump start running but no water comes out but I can feel air coming out of the opening where hose attaches. Any ideas?  
View user's profile Send private message

bperry
Posts: 158
Location: Oak Island
Reply with quote
Mon May 27, 2019 12:23 pm
is the valve open to let the water to the pump?  
View user's profile Send private message

rxheels
Posts: 36
Reply with quote
Mon May 27, 2019 1:26 pm
Yes. 2 hoses come off the pump that is connected to a thru hull fitting. One hose goes to Livewell and the other to the pump for the raw water wash down. The valve on the thru Hull is open which should let water flow to the wash down pump.  
View user's profile Send private message

Fishfull-Thinking
Posts: 73
Location: Bolivia, NC
Reply with quote
Mon May 27, 2019 2:08 pm
Do you have a screen filter on the input side of the pump? If so, check it. It may be clogged, preventing water getting to the pump.
_________________
John Lyons
Fishfull Thinking- 2018 Parker 2510 DV twin Yamaha 250\'s
  
View user's profile Send private message

Titan
Posts: 473
Reply with quote
Mon May 27, 2019 2:19 pm
Is the boat sitting in the water?  
View user's profile Send private message

rxheels
Posts: 36
Reply with quote
Mon May 27, 2019 2:37 pm
The boat is not in the water right now. Putting in the water later today or tomorrow.  
View user's profile Send private message

First Light
Posts: 367
Reply with quote
Mon May 27, 2019 4:26 pm
I had the same problem. Turned out the Jabsco quick release hose connector had worked itself just loose enough in the deck fitting so it wouldn't lift water. Pump ran but nothing came out hose.

I have no idea if this is your problem, but try looking for any loose fittings.

Good luck.
_________________
Capt. Ed
Carolina Skiff DLV 218
Yamaha 150
  
View user's profile Send private message

rxheels
Posts: 36
Reply with quote
Mon May 27, 2019 7:23 pm
Thanks everyone for the replies. I checked the fittings and screen filter for tightness. Turns out the filter reservoir was not tightened all the way so I probably am not getting a tight seal for the pump to prime. Hope that is it. Putting it in the water tomorrow to check it out. Will let you know.  
View user's profile Send private message

fishing-misfit
Posts: 76
Location: Hampstead NC
Reply with quote
Mon May 27, 2019 10:04 pm
rxheels wrote:
Thanks everyone for the replies. I checked the fittings and screen filter for tightness. Turns out the filter reservoir was not tightened all the way so I probably am not getting a tight seal for the pump to prime. Hope that is it. Putting it in the water tomorrow to check it out. Will let you know.

Had the same problem with mine 2 weeks ago. Found the filter screen housing was loose and sucking air, finger tightened and worked perfect. Hope it's a simple fix for you
  
View user's profile Send private message

DOGKILLR
Posts: 1115
Location: Mooresville, NC and Harkers Island
Reply with quote
Wed Aug 07, 2019 2:57 pm
I got tired of failing pumps. My new boats washdown pump holds 5 gallons.
_________________
2019 Southern Cross 23
  
View user's profile Send private message

Lucky Enuff
Posts: 42
Location: OIB NC
Reply with quote
Wed Aug 07, 2019 10:59 pm
At my age it works better at about 2 gal level!  
View user's profile Send private message

DOGKILLR
Posts: 1115
Location: Mooresville, NC and Harkers Island
Reply with quote
Wed Aug 21, 2019 8:50 am
Lucky Enuff wrote:
At my age it works better at about 2 gal level!


Actually mine does too.
  
View user's profile Send private message

twoturnin
Posts: 453
Location: Oak Island NC
Reply with quote
Tue Sep 10, 2019 1:35 pm
One of my Baitmasters is 22 yrs old and still going. Washdown side.
_________________
There I was 40,000 ft one burnin and one turnin

1999 24 Albie-16 Tracker-16 Lowe -12 jonboat-17 Mohawk-10 canoe
  
View user's profile Send private message Send e-mail

woodygo
Posts: 281
Location: Oak Island
Reply with quote
Tue Sep 10, 2019 3:04 pm
Mine did the same last spring, Found a small crack in the threads of the filter screen bowl that allowed air in. Replaced filter screen housing and that took care of it.  
View user's profile Send private message


Post new topic   Reply to topic


Jump to:   

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Raw water wash down - SaltwaterCentral.Com

*