Scroller block script - SaltwaterCentral.Com

Post new topic   Reply to topic
 

tampabob
Posts: 7
Reply with quote
Tue Dec 04, 2007 1:21 am
I took an html scroller script that has down/up/stop/top buttons and put it in a block using $content .=' tag. The block formated correctly, however,
when you click any of the buttons you get "out of memory". I checked my php.ini and have max memory at 32m and max post at 16m. If I open the html script using window explorer it will work properly.

Can anyone give me a hand or suggest a good script to down load.
  
View user's profile Send private message Visit poster's website

Capt_Dave
Posts: 12331
Location: Cape Fear, NC
Reply with quote
Tue Dec 04, 2007 6:50 am
Tampa,
Post the code here if you can useing the code buttons above in the post window.

If you get banned or it does not work just e-mail it to me and I will look at it. (Include your IP address if you get banned)

Scrollers can be a pain to get working right.

Something else I just thought of.....
Your out of mem error....are you using full size photos and just giving them a new size (height and width) or actulaly creating thumbnails and using them?

If you are using full size photos.....I bet that is it....

Dave
_________________
Captain Dave Tilley
910-264-3973

Let\'s go kill something!
Carolina Beach Fishing Charters
  
View user's profile Send private message Send e-mail

Capt_Dave
Posts: 12331
Location: Cape Fear, NC
Reply with quote
Tue Dec 04, 2007 7:04 am
Bob,
I was just looking through your site. Just a couple of recommandations....

First Suggestion....
I would lose 8.0 You are just asking to get hacked. It is full of security holes.

http://ravenphpscripts.com is what you want.

It is based on 7.6 . I has been coded from the ground up for security. I am a very minor part of the dev team on it.

Hit the forums there and search 8.0 and see what you get. They get asked for hacked help all the time from 8.0 users. There is no way to secure it.

Second suggestion....
lose any referance to nuke. That just makes it easier for the kiddies to find you. Hit google with phpnuke 8.0 as an example

Third suggestion....
When I mess with your scroll blocks I get a blocked scripting window from my browser. I do not know what you are doing but IE does not like it.

Just trying to help...

Dave
_________________
Captain Dave Tilley
910-264-3973

Let\'s go kill something!
Carolina Beach Fishing Charters
  
View user's profile Send private message Send e-mail

tampabob
Posts: 7
Reply with quote
Wed Dec 05, 2007 12:18 am
Thanks for the suggestions. I have the scrollers working properly now. I had the memory leak because I used $content .=' The (.) was causing the problem. Since many of these types of scripts are written in html, the easiest way to get them into php is with the $content statement. Then you just need to watch out for other single quotes as php will give you an error.

I created another problem by trying to add a 2nd script. Modifying a second copy can really cause problems.

Ron, who wrote the script I was trying to use gave me this website link (http://www.gdevresources.com/Pages/Scripts/Dynamicscroller/DScroller.shtml) to use the multiple scroller wizard on his website. Aside from changing the id tag there are several references within the javascript that also needs changing. The wizard will take care of all of that for you.

Bob
  
View user's profile Send private message Visit poster's website

tampabob
Posts: 7
Reply with quote
Wed Dec 05, 2007 4:24 am
Dave,

I believe I downloaded the most current patched version of 8.0 from phpnuke.org. However I did get the 80patchedw3dot4. Comparing the 3.4 to what I currently have seems to be the same except for some variable name differences. The routines seem to be the same in both.
I had also downloaded sentinel but did not try to add it yet.
  
View user's profile Send private message Visit poster's website

Capt_Dave
Posts: 12331
Location: Cape Fear, NC
Reply with quote
Wed Dec 05, 2007 6:31 am
8.0 from phpnukedotorg

Anything that came from there is BAD MOJO. There is NO way to secure it without rewriteing it from scratch. After 7.6 they changed the database for the 1 millionth time and where still using include vs include_once all through the code. This is a noobie error and leaves you open to remote scripting hacks.

To give you an example....this site is tested over 1000 times a day by hackers and script kiddies. They have gotten through once in 3 years but Sentinial stays very busy here. It is built on 6.9 patched.

All of my new sites are built on RN current.

Dave
_________________
Captain Dave Tilley
910-264-3973

Let\'s go kill something!
Carolina Beach Fishing Charters
  
View user's profile Send private message Send e-mail

Post new topic   Reply to topic


Jump to:   

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Scroller block script - SaltwaterCentral.Com