Garmin 7610 shutting down - SaltwaterCentral.Com

Post new topic   Reply to topic
 

Capt_Dave
Posts: 11965
Location: Cape Fear, NC
Reply with quote
Wed Aug 21, 2019 9:24 pm
I have a pair of Garmin 7610 screens. The other day one of them just shut off. Since then .....it will boot and then a few mins later shut down and will not start again for a while.

I bought a 8610 to replace it but geez......2 1/2 years on a unit that costs more than a LOT of cars I have owned over the years. I have a Northstar 951 built in the mid 80ís that still kicking.

Cheap ass junk if you ask me!

Dave
_________________
Captain Dave Tilley
910-264-3973

Let\'s go kill something!
Carolina Beach Fishing Charters
  
View user's profile Send private message Send e-mail

zigzag
Posts: 2066
Reply with quote
Thu Aug 22, 2019 12:38 am
I agree!  
View user's profile Send private message

Curmudgeon
Posts: 1392
Location: Faith/Southport
Reply with quote
Thu Aug 22, 2019 2:31 am
I'll give you $200 for the carcass, plus shipping ... wtg   
View user's profile Send private message

surffishn
Posts: 207
Location: Trenton NC.
Reply with quote
Thu Aug 22, 2019 3:14 am
Yikes I have one ! Haven't had any trouble yet. But only a year old. Did you contact Garmin support? Seems like it could be a easy fix.
_________________
Wellcraft 32CC
\"Double Play\"
Scout 200 Bay Scout
  
View user's profile Send private message

Capt_Dave
Posts: 11965
Location: Cape Fear, NC
Reply with quote
Thu Aug 22, 2019 3:10 pm
Curmudgeon wrote:
I'll give you $200 for the carcass, plus shipping ... wtg


No but thanks for the offer
_________________
Captain Dave Tilley
910-264-3973

Let\'s go kill something!
Carolina Beach Fishing Charters
  
View user's profile Send private message Send e-mail

thebeav
Posts: 5
Reply with quote
Fri Aug 23, 2019 12:44 pm
Exact same issue with one of my Garmin 7212 units. 3 years old and useless. Just replaced both of them with Garmin 1242xsve  
View user's profile Send private message

Lunchmoney
Posts: 239
Location: Huntersville
Reply with quote
Fri Aug 23, 2019 4:12 pm
Had a similar issue with a 741XS. Removed the inline fuse from the circuit and haven't had a problem since.  
View user's profile Send private message

BeeReel
Posts: 728
Location: Wilmington, NC
Reply with quote
Sun Aug 25, 2019 5:19 pm
Dangit I have one on my boat! Already have to send the unit back to Garmin because the glass is delaminating. Sucky part is, there is another issue - I run both a transom mount and thru-hull 'ducer. The temp is totally whacked out (reading ~20 degrees F currently) and I'm having problems with the conventional sonar at idle from the transom 'ducer and lose bottom lock on the thru-hull as soon as I'm up on plane. Some of these items could be the unit itself. But I have to send the unit back for the screen issue first - they repair the glass - and then diagnose the 'ducer problems. Which very well may require the unit to be sent back again. UGH
_________________
2016 22 ft Robalo Cayman
2016 Yamaha F200

SOLD - Pearl Miner
2009 25 ft Carolina Classic
Volvo D4 300
  
View user's profile Send private message

werewolf0711
Posts: 3078
Reply with quote
Mon Aug 26, 2019 11:38 pm
BeeReel wrote:
Dangit I have one on my boat! Already have to send the unit back to Garmin because the glass is delaminating. Sucky part is, there is another issue - I run both a transom mount and thru-hull 'ducer. The temp is totally whacked out (reading ~20 degrees F currently) and I'm having problems with the conventional sonar at idle from the transom 'ducer and lose bottom lock on the thru-hull as soon as I'm up on plane. Some of these items could be the unit itself. But I have to send the unit back for the screen issue first - they repair the glass - and then diagnose the 'ducer problems. Which very well may require the unit to be sent back again. UGH


Your transducer issue can also be in the transducers themselves. The bottom lock is typically inherent of mounting location and the water it has. Are both transuducers reading the same off temps or is one reading correct and one not?

As for the 7600 issue. It sucks but there are quite a few faulty unit in that line. I'm hoping the 8600 series has that worked out. I just put a 8612 in mine to replace a 4210 that was 8 years old without a single hiccup. The 8612 lost sonar on my first offshore trip when I tried switching from one ducer to the other and after about 15 mins it came back up and worked the whole time and hasn't gave an issue since, knock on wood!
_________________
2011 SEAHUNT Gamefish 25
TWIN 150 Yamahas
McAttacK

Team Kraken
JB Custom Rods
Check US out on Facebook!
McAttacK Fishing Team

www.mcattackfishing.com
  
View user's profile Send private message

Post new topic   Reply to topic


Jump to:   

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Garmin 7610 shutting down - SaltwaterCentral.Com

*